Ankündigung

Einklappen
Keine Ankündigung bisher.

Fehlermeldung beim Zugriff auf die ACDSee Pro10.0 Datenbank

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Fehlermeldung beim Zugriff auf die ACDSee Pro10.0 Datenbank

    Hallo,
    seit gestern kann ich nicht mehr auf die Datenbank zugreifen
    Version:ACDPro 10.0.
    Es erscheint angehängte Fehlermeldung.

    Ich habe im Explorer den Pfad geöffnet. Die Datenbank ist physikalisch vorhanden.

    Ich habe auch schon den einen oder anderen Vorschalg aus dem ACDForum probiert:
    zB: Originaldatenbank umbenennen, Neue Datenbank anlegen lassen, Originaldatenbank rückbennen...

    Funktioniert hat bislang noch nichts.

    Hat jemand von euch noch eine Idee was ich noch probieren könnte, bzw. kann es sein, dass irgendetwas meine Datenbank zerstört hat? Gibt es eine Möglichkeit diese wieder zu reparieren?


    Würde mich über Tipps und Ratschläge freuen, denn ich hab schon vieeeeeele Stunden in die Bearbeitung gesteckt :-(


    Vielen Dank im Vorhinein

    LG

  • #2
    Wenn Du die Verwaltungsdaten eingebettet hast, kannst Du einfach eine neue Datenbank anlegen und die Bilder wieder importieren. Dauert halt leider je nach Menge seine Zeit.

    Kommentar


    • #3
      Erster Versuch:
      - beende AC
      - Erstelle eine Kopie deiner Datenbank
      - lösche alle CDX-Dateien in der Datenbank
      - starte AC

      Anmerkung: Ich mache bei AC Pro/Ulti 10 die Erfahrung, dass es manchmal unsichtbar (ohne sichtbares Fenster) weiter läuft und lasse deshalb gerne den Process Hacker zur Kontrolle mitlaufen.

      Kommentar


      • #4
        @scx: ja. Hab ich gemacht. Es sind halt 32000 dateien. Das dauert halt wieder ewig. Wenn nichts funktioniert wirds wohl eh nicht ausbleiben.

        @emil: ok. Probier ich. Die kopie mach ich zwecks backup oder? Dh die cdx dateien lösch ich in meiner original datenbank. Ok

        Meld mich morgen mit dem ergebnis.

        Danke euch zwei für die tipps

        Lg

        Kommentar


        • #5
          @Emil: Hab das probiert, leider ohne Erfolg.

          Hast du noch einen 2. Verusch? :-)

          Kommentar


          • #6
            Zitat von tomsn81 Beitrag anzeigen
            @Emil: Hab das probiert, leider ohne Erfolg.
            Und? Was ist passiert? Sind die CDX Dateien neu erstellt worden? Ein Teil? Alle? Keine? Hast du eine Fehlermeldung erhalten? Welche?

            2ter Versuch: Lösche zusätzlich zu den CDX-Dateien noch die Dateien Thumbs1.fpt, Thumbs2.fpt und Thumbs3.fpt. Achtung hierbei gehen die Minibilder verloren und müssen danach in AC neu erstellt werden.
            Zuletzt geändert von Emil; 14.04.2017, 21:23.

            Kommentar


            • #7
              @Emil: Alle CDX Dateien sind neu erstellt worden. Beim Starten kam wieder der gleiche Fehler wie im Anhang meines ersten Posts.

              Hab jetzt noch die Thumbs*.fpt Dateien gelöscht, dann hat er wieder gestartet und meine Datenbank konnte wieder geöffnet werddn.

              Mit Minibilder meinst du die in der Fotos Ansicht, oder? Die sind jetzt weg. Wie kann ich die Minibilder wieder neu erstellen lassen?

              PS: Danke schon mal soweit für deine Hilfe!!! Der ACD Support konnte mir bisher nicht so viel dazu sagen wie du :-)

              Kommentar


              • #8
                Zitat von tomsn81 Beitrag anzeigen
                ... dann hat er wieder gestartet und meine Datenbank konnte wieder geöffnet werddn.
                :-)

                Mit Minibilder meinst du die in der Fotos Ansicht, oder? Die sind jetzt weg. Wie kann ich die Minibilder wieder neu erstellen lassen?)
                Jetzt wird es haarig! Offenbar ist eine der "Thumbs*.fpt" defekt.

                "Thumbs1.fpt enthält die Master Minibilder
                "Thumbs2.fpt enthält die Minibilder für den Verwalten-Modus, Sie werden aus den Master-Minibilder erstellt
                "Thumbs3.fpt enthält die Minibilder für den Fotos-Modus. Sie werden ebenfalls aus den Master-Minibilder erstellt.

                Der nächste Versuch wäre, den Backup wieder herzustellen und danach alle CDX sowie "Thumbs2.fpt" und Thumbs3.fpt" zu löschen, in der Hoffnung das "Thumbs1.fpt" nicht defekt ist. Aber leider ist in der Regel eben diese Datei mit den Master-Minibildern betroffen.

                Wenn das nicht klappt hilft nur, alle Minibilder neu erstellen zu lassen. Dazu werden alle Bilder (z.B. "Bildbank") im Verwalten-Modus aufgerufen und die Minibilder von AC neu erzeugt (Extras - Metadaten - Miniaturansichten und Metadaten erneuern). Ob dann auch die Minibilder für den Fotos-Modus erzeugt werden weis ich nicht, so eine Macke hatte ich bislang noch nicht.

                Wenn dein AC wieder ordentlich läuft, solltest du auf jeden Fall mal Extras - Datenbank - Datenbank optimieren aufrufen und die Tabelle säubern lassen. Das kann dann allerdings eine Weile dauern.
                Zuletzt geändert von Emil; 14.04.2017, 21:25.

                Kommentar


                • #9
                  Hallo Emil:

                  Hab eben das Problem noch etwas detaillierter analysiert.

                  Thumbs1.ftp hat 0KB ==> wurde also zerstört. (Hättest du mich nicht darauf hingewiesen, wüsste ich bis jetzt noch immer nicht den Grund, der Support konnte mir nicht soweit helfen wie du...)

                  Ich habe Thumbs1.ftp gelöscht, dann hat ACDSee Pro wieder gestartet. Wie erwartet waren die Miniaturansichten im Foto Modus weg.. Die Miniaturansichten im Verwalten Modus waren interessanter Weise zum Teil noch da.

                  Ich hätte dann auf Metadaten erneuern geklickt, aber das ist ausgegraut. Das kann man nur durchführen, wenn man Fotos selektiert. Das heißt ich müsste jetzt all meine Fotos irgendwie markieren und dann jeweils die Funktion ausführen...Das ist mir irgendiwe zu mühsam...

                  ==> Ich habe jetzt schonmal das neu katalogisieren gestartet, ich glaub das is einfacher. Zum Glück hab ich meine Änderungen (Tags, Beschriebung) direkt in die Dateien eingebettet, dadurch ist der Verlust nicht allzu groß.. Einzig das Katalogisieren dauert bei 30000 Bildern wieder ewig... :-(

                  Fazit:
                  Werd küfntig BACKUPs der Datenbank erstellen, und nochmal beim Support anmerken, dass sie diesen Bug endlich fixen sollen. Das trifft ja scheinbar nicht nur mich, wenn ich mir die Foreneinträge so durchsehe.. Es ist eigentlich eine Frechheit so eine Software auszuliefern und auch noch über 60 Euros dafür zu verlangen... :-(

                  Danke jedenfalls nochmal für deine Hilfe!!
                  LG

                  Kommentar


                  • #10
                    Zitat von tomsn81 Beitrag anzeigen
                    Die Miniaturansichten im Verwalten Modus waren interessanter Weise zum Teil noch da.
                    Klar, die werden ja auch , soweit vorhanden aus Thumbs2.fpt gelesen

                    Ich habe jetzt schonmal das neu katalogisieren gestartet, ich glaub das is einfacher. Zum Glück hab ich meine Änderungen (Tags, Beschriebung) direkt in die Dateien eingebettet, dadurch ist der Verlust nicht allzu groß.. Einzig das Katalogisieren dauert bei 30000 Bildern wieder ewig... :-(
                    Super! Immer artig einbetten ist die bester Versicherung für die DB. Aber leider ein irrer Aufwand für die Backups, wenn man viele JPGs hat. Aber das ist ein völlig anderes Thema.

                    Bei mir dauert das katalogisieren etwa 40 Stunden für 230.000 Bilder.

                    ... und nochmal beim Support anmerken, dass sie diesen Bug endlich fixen sollen. Das trifft ja scheinbar nicht nur mich, wenn ich mir die Foreneinträge so durchsehe..
                    Jepp, die FoxBase Datenbank gehört endlich in Rente geschickt. Aber nicht unbedingt weil sie fehlerhaft ist; meine dbs gehen praktisch nie kaputt [crossed fingers], sondern weil sie viel zu langsam ist und die Gimmiks (Optimieren und Pflege) bei dicken dbs nicht mehr wirklich funktionieren. Bei mir ist die Optimierung praktisch unbrauchbar, es ist leichter eine völlig neue db zu erstellen.
                    Zuletzt geändert von Emil; 16.04.2017, 23:18.

                    Kommentar


                    • #11
                      @Emil: Hab jetzt noch ein wenig mit dem Support geschrieben, hab das ganze aber jetzt aufgegeben :-)

                      Angeblich ist mein Virenscanner schuld, bzw. hab ich Fragmentierungsprobleme mit Windows, bzw. ist meine Festplatte kurz vorm abkratzen, denn ansonsten kann es ja nicht sein, dass eine Datei einfach zerstört wird.

                      Schon komisch, dass wenn man in Google eintippt: "ACDSeePro kann keine Verbindung zur Datenbank finden" seitenweise Einträge von unterschiedlichsten Usern in unterschiedlichsten Foren angezeigt werden...

                      Hab jetzt ~ 20000 meiner ~35000 Bilder wieder neu katagolisiert und die Thumbs1.fpt hat jetzt schon 1.4 GB... Da wundert mich nix, dass da hin und wieder mal was passieren kann.

                      Vorallem deckt sich das mit deiner Aussage, dass das Ding ewig dauert bei 230000 Bildern :-)


                      Naja, aber wie gesagt: Die Damen und Herren sehen den Fehler ja nicht bei Ihnen, sondern bei mir :-)

                      Danke jedenfalls trotzdem nochmal für deine Hilfe

                      LG THomas

                      Kommentar


                      • #12
                        Meine Thumb1.fpt ist etwa 10,7GB fett. Die gesamte db verbrät etwa 20GB.

                        Wenn man bedenkt, dass die db für jedes Bild einen Thumbnail vorhalten muss, und jedes Thumbnail etwa 50KB belegt, wird der Speicherbedarf eher verständlich. Mann kann natürlich argumentieren, das für 340Pixel-Bilder auch 10KB reichen würden, aber dann wäre man schnell bei den matschigen Minibildern à la LR.

                        Wozu man auf modernen Rechnern allerdings noch Thumbs2.fpt und Thumbs3.fpt braucht wird mir wohl ein Rätsel bleiben. Man könnte die verkleinerten Varianten der Thumbnails auch on the fly berechnen.

                        PS. Ich habe immer wieder den Eindruck, das ACDSystems das Programm nie mit vielen großen Dateien testet. Wie soll man sich sonst erklären, dass katalogisierte Dateien mit 1-1,9MB als "Mittel" und Dateien über 8MB als "Größte" bezeichnet werden. Dateien unter 25MB kommen bei mir praktisch nicht vor. Auch die Funktionen "Datenbank optimieren" und "Datenbankpflege" sind bei mir so langsam, dass ich leichter eine neuen Katalog erstellen kann, denn da bekommt man immerhin eine funktionierende Fortschrittsanzeige.


                        Kommentar


                        • #13
                          Für die Vorschaubilder für die schnelle Ansicht benutzt ACDSee die bei JPG als Voreinstellung eingestellte Qualität. Darum stelle ich die immer etwas herunter. Spart Platz auf der Festplatte. Ich weiß aber nicht, ob sich das auch auf die Datenbankgröße auswirkt.

                          Kommentar

                          Lädt...
                          X